LesDeLLiens.com: : Linux ? - LesDeLLiens.com

Aller au contenu

  • 7 Pages +
  • 1
  • 2
  • 3
  • 4
  • 5
  • Dernière »
  • Vous ne pouvez pas commencer un sujet
  • Vous ne pouvez pas répondre à ce sujet

Inspiron 1720
: Linux ?

#41 L'utilisateur est hors-ligne   x0r Icône

  • Newbie
  • Groupe : Membre
  • Messages : 35
  • Inscrit(e) : 07 Jul 07
  • Sexe:Homme

Posté 26 August 2007 à 08:17:18

Voir le messageB1bou91, le le 21-08-07 à 00:19:46, dit :

J'ai le wifi N avec ubuntu et ca marche également chez moi. :)

Les machines Dell sont assez similaires entre elle. Donc n'hésitez pas à lire les tutoriaux pour les autres machines!


Je viens de faire marcher le Wi-Fi sur ma Debian, mais j'ai quand même dû me recompiler un tout nouveau noyau, j'ai maintenant la version 2.6.22.2. Mais c'est pas encore du N...

(Oui, j'_ai_ un routeur et une carte N, mais je pense qu'il va falloir attendre un peu avant d'avoir du N sous Linux... Quoique... Maintenant j'ai du Wi-Fi dans toute la maison \o/ )

Ce message a été modifié par Marx0r - 26 August 2007 à 12:10:25.

Config:
Inspiron 1720, Core 2 Duo T7100 @ 1,80GHz, nVIDIA 8600GT, 160Go + 500Go SATA, 2Go RAM, Intel 4965AGN, Bluetooth, clavier QWERTY-US, Gentoo Linux

<Ishen> Windows ? Voilà un nom très indicatif de par où il faut balancer cet OS... (BashFR)

<Noche> Le problème avec linux, c'est que des fois ça tombe en panne
<Noche> Le problème avec Windows, c'est que des fois ça tombe en marche
(BashFR)
0

#42 L'utilisateur est hors-ligne   x0r Icône

  • Newbie
  • Groupe : Membre
  • Messages : 35
  • Inscrit(e) : 07 Jul 07
  • Sexe:Homme

Posté 26 August 2007 à 12:15:50

J'ai tenté la configuration suivante :
Section "InputDevice"
	Identifier	 "Synaptics Touchpad"
	Driver		 "synaptics"
	Option		 "SendCoreEvents" "true"
	Option		 "Device" "/dev/psaux"
	Option		 "Protocol" "auto-dev"
	Option		 "HorizScrollDelta" "0"
	Option		 "SHMConfig" "on"
EndSection

il doit manquer quelque chose ...

Sinon je n'ai pas essayé de faire marcher la webcam encore.
[/quote]

Sur ma Debian, le serveur Xorg ne trouve pas mon touchpad, mais je peux m'en servir quand même... Mais sans le scroll, ce qui est quand même assez ch... parfois. Pour la webcam, un lsusb donne des infos intéressantes mais j'ai essayé deux trois trucs sans succès, peut-être qu'il faudra chercher sur Google :-p
Config:
Inspiron 1720, Core 2 Duo T7100 @ 1,80GHz, nVIDIA 8600GT, 160Go + 500Go SATA, 2Go RAM, Intel 4965AGN, Bluetooth, clavier QWERTY-US, Gentoo Linux

<Ishen> Windows ? Voilà un nom très indicatif de par où il faut balancer cet OS... (BashFR)

<Noche> Le problème avec linux, c'est que des fois ça tombe en panne
<Noche> Le problème avec Windows, c'est que des fois ça tombe en marche
(BashFR)
0

#43 L'utilisateur est hors-ligne   B1bou91 Icône

  • DeLLien Expert
  • PipPipPip
  • Groupe : Membre
  • Messages : 339
  • Inscrit(e) : 15 Nov 06
  • Localisation:Lyon ou Essonne

Posté 26 August 2007 à 13:03:39

Voir le messageMarx0r, le le 26-08-07 à 13:15:50, dit :

J'ai tenté la configuration suivante :
Section "InputDevice"
	Identifier	 "Synaptics Touchpad"
	Driver		 "synaptics"
	Option		 "SendCoreEvents" "true"
	Option		 "Device" "/dev/psaux"
	Option		 "Protocol" "auto-dev"
	Option		 "HorizScrollDelta" "0"
	Option		 "SHMConfig" "on"
EndSection

il doit manquer quelque chose ...

Sinon je n'ai pas essayé de faire marcher la webcam encore.


Sur ma Debian, le serveur Xorg ne trouve pas mon touchpad, mais je peux m'en servir quand même... Mais sans le scroll, ce qui est quand même assez ch... parfois. Pour la webcam, un lsusb donne des infos intéressantes mais j'ai essayé deux trois trucs sans succès, peut-être qu'il faudra chercher sur Google :-p


Sert toi du topic quasi unique de l'inspiron 1520 sur ubuntuforums.org pour ta webcam

As tu essayé de reconfigurer ton xorg?
[Vostro 1500] C2D T7300::Ram 2048Mo::8600GT::WSXGA+ & Cam::DD 160/7200Tr::Bat. 9 Cells::Wifi-N,Bluetooth & Casque::MX Revolution::Télécommande+Wiimote
Ubuntu Gutsy AMD 64 [VirtualBox pour Vista pro sometimes].
0

#44 L'utilisateur est hors-ligne   Daëavelwyn Icône

  • Newbie
  • Groupe : Membre
  • Messages : 16
  • Inscrit(e) : 29 Aug 07

Posté 29 August 2007 à 00:09:21

le wiki ubuntu propose une solution inspiré du 1520 mais qui marche bien pour mon 1720 perso :

http://doc.ubuntu-fr.org/dell_inspiron_1720
0

#45 L'utilisateur est hors-ligne   NeLo Icône

  • Newbie
  • Groupe : Membre
  • Messages : 14
  • Inscrit(e) : 05 Dec 06
  • Sexe:Homme
  • Localisation:Saint-Etienne

Posté 04 September 2007 à 09:48:17

Marxor, as-tu eu des problemes lors de l'installation de ta debian, personnelement j'essaye de l'installer depuis que j'ai recu mon laptop, mais a chaque fois il y a un probleme avec le serveur X du coup je suis bloqué en mode console. Il me dit qu'il n'arrive pas a le lancer.

J'utilise le cd d'installation par internet : debian-40r1-i386-netinst.iso. Je n'ai pas essayé avec la mise à jour, ni avec les cd normaux mais je compte le faire.
Je precise que sur mon fixe je n'ai eu ucun probleme pour l'installer avec le même cd.

Merci d'avance pour ton aide.

NeLo
[1720] : T7500, ultrasharp 1920*1200, wifi N, 8600m GT, 2Go DDR2
0

#46 L'utilisateur est hors-ligne   B1bou91 Icône

  • DeLLien Expert
  • PipPipPip
  • Groupe : Membre
  • Messages : 339
  • Inscrit(e) : 15 Nov 06
  • Localisation:Lyon ou Essonne

Posté 04 September 2007 à 11:16:50

Voir le messageNeLo, le le 04-09-07 à 10:48:17, dit :

Marxor, as-tu eu des problemes lors de l'installation de ta debian, personnelement j'essaye de l'installer depuis que j'ai recu mon laptop, mais a chaque fois il y a un probleme avec le serveur X du coup je suis bloqué en mode console. Il me dit qu'il n'arrive pas a le lancer.

J'utilise le cd d'installation par internet : debian-40r1-i386-netinst.iso. Je n'ai pas essayé avec la mise à jour, ni avec les cd normaux mais je compte le faire.
Je precise que sur mon fixe je n'ai eu ucun probleme pour l'installer avec le même cd.

Merci d'avance pour ton aide.

NeLo


Ok la solution à faire...

tu fais ton installation normale... puis après il faut éditer ta liste de sources, de préférence en debian sid, mettre à jour les nouveaux paquets. (Y'en aura un certain nombre :) )

Bien sur il te fat une connection filaire pendant ce temps la
[Vostro 1500] C2D T7300::Ram 2048Mo::8600GT::WSXGA+ & Cam::DD 160/7200Tr::Bat. 9 Cells::Wifi-N,Bluetooth & Casque::MX Revolution::Télécommande+Wiimote
Ubuntu Gutsy AMD 64 [VirtualBox pour Vista pro sometimes].
0

#47 L'utilisateur est hors-ligne   Daëavelwyn Icône

  • Newbie
  • Groupe : Membre
  • Messages : 16
  • Inscrit(e) : 29 Aug 07

Posté 04 September 2007 à 12:20:59

Marxor -> si ta carte est une nvidia et que tu désires la 3D, utilise les drivers proprio (malheuresement les driver libre pour nvidia ne gere pas encore openGL).

le driver nvidia : http://www.nvidia.com/object/unix.html

Personellement pour ma 8600M GT j'utilise le pilote 100.14.09, qui fonctionne bien, bien que en version beta .

Pour l'installer tu auras besoin du paquet xserver-xorg-dev et de gcc.

bonne chance :)
0

#48 L'utilisateur est hors-ligne   x0r Icône

  • Newbie
  • Groupe : Membre
  • Messages : 35
  • Inscrit(e) : 07 Jul 07
  • Sexe:Homme

Posté 04 September 2007 à 16:02:26

Voir le messageDaëavelwyn, le le 04-09-07 à 13:20:59, dit :

Marxor -> si ta carte est une nvidia et que tu désires la 3D, utilise les drivers proprio (malheuresement les driver libre pour nvidia ne gere pas encore openGL).

le driver nvidia : http://www.nvidia.com/object/unix.html

Personellement pour ma 8600M GT j'utilise le pilote 100.14.09, qui fonctionne bien, bien que en version beta .

Pour l'installer tu auras besoin du paquet xserver-xorg-dev et de gcc.

bonne chance :)


Ne vous inquiétez pas pour moi, j'ai réussi depuis longtemps à gérer le problème de la carte nVIDIA, vu que toutes mes machines chez moi en sont équipées.

Par contre, la webcam ne marche pas encore chez moi, et pour le son et le Wi-Fi, j'ai dû recompiler mon noyau (avec la bonne config' (make menuconfig) et la prise en charge de la puce 'Intel HDA' _dans_ le noyau ET PAS en tant que module!!) Pour le Wi-Fi, j'utilise iwl4965, avec la version patchée de mac80211 (faudra refaire un make clean; make-kpkg clean; make-kpkg --initrd --revision=ce_que_vous_voulez_1.0 kernel_image en tant que root avant de compiler le module, faudra probablement réinstaller le driver nVIDIA au passage mais s'pas grave) et ça a l'air de marcher assez bien. Quand vous avez l'impression que la connec' n'est pas super, n'hésitez pas à désactiver le Wi-Fi dans knetworkmanager ou autres, puis le relancer.

Je sais pas pourquoi mais j'avais pas réussi à importer la config' de mon dernier kernel quand je voulais recompiler le mien (je sais que c'est dans /boot/quelque_part), donc vérifiez bien que vous activez la prise en charge de plus d'1 Go de RAM, l'Ethernet c'est une Broadcom 44xx, le bluetooth une Broadcom 203x (j'crois)).

Par contre, depuis un bon bout de temps, KbluetoothD me plante à la gueule dès que je le lance avec le Bluetooth activé. Avant ça marchait... -_-

Ceci dit, au passage, j'ai utilisé des DVD qui étaient dans un hors-série du magazine Linux+, vu que j'avais pas de graveur et que mes DL des ISO foiraient... :-S Maintenant j'ai de jolis DVD présentables avec une bête d'étiquette et tout ;)

Ce message a été modifié par Marx0r - 04 September 2007 à 16:09:53.

Config:
Inspiron 1720, Core 2 Duo T7100 @ 1,80GHz, nVIDIA 8600GT, 160Go + 500Go SATA, 2Go RAM, Intel 4965AGN, Bluetooth, clavier QWERTY-US, Gentoo Linux

<Ishen> Windows ? Voilà un nom très indicatif de par où il faut balancer cet OS... (BashFR)

<Noche> Le problème avec linux, c'est que des fois ça tombe en panne
<Noche> Le problème avec Windows, c'est que des fois ça tombe en marche
(BashFR)
0

#49 L'utilisateur est hors-ligne   Daëavelwyn Icône

  • Newbie
  • Groupe : Membre
  • Messages : 16
  • Inscrit(e) : 29 Aug 07

Posté 06 September 2007 à 10:43:24

Merci Marxor, tes précisions vont m'être très utile je pense, car j'ai un soucis de son, lorsque je connecte un casque dans la prise casque, il ne coupe pas le son des enceintes !! de plus, je me suis rendu compte que le bouton muet du clavier ne fonctionne pas !! Peut-être l'insertion directement dans le noyau du pilote et une bonne recompilation résoudront mon problème...
Pour la Webcam, j'ai suivi le tuto ubuntu : http://doc.ubuntu-fr.org/dell_inspiron_1720 et ça marche niquel :)

Ce message a été modifié par Daëavelwyn - 06 September 2007 à 10:45:25.

0

#50 L'utilisateur est hors-ligne   B1bou91 Icône

  • DeLLien Expert
  • PipPipPip
  • Groupe : Membre
  • Messages : 339
  • Inscrit(e) : 15 Nov 06
  • Localisation:Lyon ou Essonne

Posté 06 September 2007 à 17:53:38

Est-ce que Cheese marche avec ton pc?

J'ai la webcam qui marche mais pas avec cheese :/
[Vostro 1500] C2D T7300::Ram 2048Mo::8600GT::WSXGA+ & Cam::DD 160/7200Tr::Bat. 9 Cells::Wifi-N,Bluetooth & Casque::MX Revolution::Télécommande+Wiimote
Ubuntu Gutsy AMD 64 [VirtualBox pour Vista pro sometimes].
0

#51 L'utilisateur est hors-ligne   x0r Icône

  • Newbie
  • Groupe : Membre
  • Messages : 35
  • Inscrit(e) : 07 Jul 07
  • Sexe:Homme

Posté 06 September 2007 à 18:28:19

Voir le messageDaëavelwyn, le le 06-09-07 à 11:43:24, dit :

Lorsque je connecte un casque dans la prise casque, il ne coupe pas le son des enceintes !!


Ah, ça c'est un autre truc... J'avais le même prob', mais je l'ai résolu en activant "HPET timer support" dans "Processor type and features" (make menuconfig). Ça a l'air de résoudre le problème, mais d'un autre côté, /dev/rtc déconne donc ça fait perdre 4 secondes au boot et au shutdown. Y doit y'avoir une solution pour ça.

Pour les boutons, dans Kmix j'ai dit que mon canal principal était 'front' et pas 'pcm'. Apparemment, PCM ne peut pas être coupé, Front si, donc j'ai choisi ça. Par contre, le volume règle le canal PCM.

Et l'article dans le Wiki d'Ubuntu a l'air d'avoir changé aussi, en présentant une version un peu plus élégante du "comment transformer mon Dell en super boombox" (non je déconne), sans avoir à recompiler son kernel. J'ai pas essayé, perso, mais pour celui qui a peur du Grand Make-Kpkg ça peut être sympa... Si ça marche.

Ce message a été modifié par Marx0r - 06 September 2007 à 21:14:00.

Config:
Inspiron 1720, Core 2 Duo T7100 @ 1,80GHz, nVIDIA 8600GT, 160Go + 500Go SATA, 2Go RAM, Intel 4965AGN, Bluetooth, clavier QWERTY-US, Gentoo Linux

<Ishen> Windows ? Voilà un nom très indicatif de par où il faut balancer cet OS... (BashFR)

<Noche> Le problème avec linux, c'est que des fois ça tombe en panne
<Noche> Le problème avec Windows, c'est que des fois ça tombe en marche
(BashFR)
0

#52 L'utilisateur est hors-ligne   Daëavelwyn Icône

  • Newbie
  • Groupe : Membre
  • Messages : 16
  • Inscrit(e) : 29 Aug 07

Posté 07 September 2007 à 10:58:19

Marxor ->Décidement, ton expérience m'est très utile ^_^, merci de poster pour les moins expérimenté comme moi :)

Citation

Pour les boutons, dans Kmix j'ai dit que mon canal principal était 'front' et pas 'pcm'. Apparemment, PCM ne peut pas être coupé, Front si, donc j'ai choisi ça. Par contre, le volume règle le canal PCM.


O_o' comment tu fais ça????

J'ai aussi pas mal de problème avec l'ACPI, la mise en veille ne reprend pas, et idem pour la mise en veille prolongé, je n'arrive plus non plus à avoir accès à mes tty (ctrl+alt+F*) si tu as eu ces pb aussi et que tu as réussi à les solutionner, je suis preneur ;)

Merci d'avance :)

Ce message a été modifié par Daëavelwyn - 07 September 2007 à 11:06:36.

0

#53 L'utilisateur est hors-ligne   x0r Icône

  • Newbie
  • Groupe : Membre
  • Messages : 35
  • Inscrit(e) : 07 Jul 07
  • Sexe:Homme

Posté 08 September 2007 à 21:36:50

Citation

O_o' comment tu fais ça????


Clic droit sur l'icône -> Choisir canal principal, et ensuite tu choisis 'Front' et tu cliques sur OK.

Citation

J'ai aussi pas mal de problème avec l'ACPI, la mise en veille ne reprend pas, et idem pour la mise en veille prolongé, je n'arrive plus non plus à avoir accès à mes tty (ctrl+alt+F*) si tu as eu ces pb aussi et que tu as réussi à les solutionner, je suis preneur ;)t

Merci d'avance :)


Moi, sur mon ancien noyau 2.6.22-1, j'ai vu que je ne réveillais qu'un seul coeur sur les deux, donc ça réduisait beaucoup les performances de ma machine... J'ai pas encore testé avec mon kernel 2.6.22.2 compilé par contre. Il doit manquer un truc.

Update
En fait, j'ai carrément la vidéo qui n'est plus réactivée... Je sais qu'il y a un moyen de contourner ce problème, il faudrait que je ressorte mes vieux Planète Linux. J'utilise la combinaison Fn+Echap mais ça a pas l'air de beaucoup plaire à KDE. Je verrai bien s'il y a une solution à ce problème.

Ce message a été modifié par Marx0r - 08 September 2007 à 21:52:49.

Config:
Inspiron 1720, Core 2 Duo T7100 @ 1,80GHz, nVIDIA 8600GT, 160Go + 500Go SATA, 2Go RAM, Intel 4965AGN, Bluetooth, clavier QWERTY-US, Gentoo Linux

<Ishen> Windows ? Voilà un nom très indicatif de par où il faut balancer cet OS... (BashFR)

<Noche> Le problème avec linux, c'est que des fois ça tombe en panne
<Noche> Le problème avec Windows, c'est que des fois ça tombe en marche
(BashFR)
0

#54 L'utilisateur est hors-ligne   Daëavelwyn Icône

  • Newbie
  • Groupe : Membre
  • Messages : 16
  • Inscrit(e) : 29 Aug 07

Posté 08 September 2007 à 23:11:34

merci pour le son, le muet marche tres bien maintenant, mais je n'ai toujours pas de son dans le casque kan je le branche...ça reste dans les enceintes du pc :-(
Pour les pb d'ACPI, je me demande si c'est pas le pilote nvidia qui merde a la reprise, dès que j'ai le temps je test avec un pilote vesa voir si c'est pareil

Ce message a été modifié par Daëavelwyn - 08 September 2007 à 23:14:15.

0

#55 L'utilisateur est hors-ligne   Snip_oX Icône

  • Newbie
  • Groupe : Membre
  • Messages : 32
  • Inscrit(e) : 14 Aug 07
  • Sexe:Homme
  • Localisation:Angers

Posté 09 September 2007 à 09:52:19

Sous Ubuntu, a ton tous ces problèmes également?
Moi je suis un bleu total pour linux alors je voulais m'y mettre avec mon Inspiron 1720 (pas encore commandé) et je comptais prendre Ubuntu.

Aurais-je des problèmes similaires sous cette distribution?
Merci
Image IPB
0

#56 L'utilisateur est hors-ligne   Daëavelwyn Icône

  • Newbie
  • Groupe : Membre
  • Messages : 16
  • Inscrit(e) : 29 Aug 07

Posté 09 September 2007 à 10:01:09

Salut snip_ox, je ne crois pas que Dell propose une version du inspiron 1720 avec ubuntu, donc si tu l'installes toi meme, tu risque effectivement de rencontrer ces problèmes. il est tout de même à noter que le monde de l'open source évoluant très vite, en quelques mois, beaucoup de ces problèmes peuvent être résolus, notament ave l'arrivé en octobre de la nouvelle version de ubuntu (7.10). Donc pour l'instant, personellement j'ai fait un dual-boot d'un côté le windows vista filé ave l'inspiron 1720 et de l'autre ubuntu...Heu...en meme temps, ça doit faire un mois que j'ai pas booté sous vista ;)

Voilà pour mon expérience :)
0

#57 L'utilisateur est hors-ligne   Snip_oX Icône

  • Newbie
  • Groupe : Membre
  • Messages : 32
  • Inscrit(e) : 14 Aug 07
  • Sexe:Homme
  • Localisation:Angers

Posté 09 September 2007 à 10:12:05

D'accord, je te remerci pour ta réponse.
Moi je comptais aussi faire un dual-boot parce que je connais pas grand chose sous Linux mais que je m'y intéresse vraiment.
Est-ce que tu aurais des forums sur lesquels je pourrais apprendre les bases de Linux?
Merci
Image IPB
0

#58 L'utilisateur est hors-ligne   x0r Icône

  • Newbie
  • Groupe : Membre
  • Messages : 35
  • Inscrit(e) : 07 Jul 07
  • Sexe:Homme

Posté 09 September 2007 à 10:25:58

ATTENTION: Ce tuto est OBSOLÈTE car la plupart des choses à installer sont maintenant déjà inclus dans les noyaux à partir de la 2.6.24. Si vous avez un vieux noyau, je vous conseille VIVEMENT de le mettre à jour, votre Inspiron et votre manchot vous diront merci.

Voir le messageDaëavelwyn, le le 09-09-07 à 00:11:34, dit :

merci pour le son, le muet marche tres bien maintenant, mais je n'ai toujours pas de son dans le casque kan je le branche...ça reste dans les enceintes du pc :-(


Malheureusement, je crois qu'il va falloir compiler un nouveau noyau. A moins que tu n'aies déjà fait ça pour installer le pilote Wi-Fi... Je te propose alors de compiler le même noyau que moi, avec les mêmes paramètres que le mien. Voici le super-HOWTO écrit par moi-même.

Je vais essayer d'être le plus clair possible. Si t'as une question, pose-la moi, ça t'évitera peut-être de crasher toute ton installation.

Les commandes à taper dans une console sont en gras.

Attention Ceci est un noyau qui fonctionne sur ma machine. Elle peut ne pas fonctionner sur la vôtre. Aussi, moi je suis sur une Debian, j'admets que la plupart d'entre vous êtes sur une Ubuntu ou similaire. Après l'installation, vous devrez réinstaller les drivers pour le Wi-Fi et pour la carte graph' ! Enfin, je vous recommande fortement d'imprimer ceci ou de le suivre sur une autre machine, parce qu'il va falloir rebooter et vous n'aurez pas toujours votre GNOME ou KDE.

COMPILER UN NOUVEAU NOYAU
  • Ouvrez une console.
  • On va d'abord télécharger le noyau. Tapez (ou copiez-collez) sudo cd /usr/src; wget "http://www.kernel.org/pub/linux/kernel/v2.6/linux-2.6.22.2.tar.bz2"
  • Extrayez le .bz2: sudo tar xvjf linux-2.6.22.2.tar.bz2.
  • Téléchargez le config.txt en pièce jointe dans votre répertoire personnel.
  • Tapez sudo cp ~/config.txt /usr/src/linux-2.6.22.2/.config pour copier le fichier de configuration au bon endroit avec le bon nom.
  • Tapez cd /usr/src/linux-2.6.22.2 pour vous placer dans le répertoire des sources du nouveau noyau.
  • Ensuite, tapez sudo make menuconfig pour voir si les scripts make fonctionnent bien. Si vous vous retrouvez sur un menu console, c'est que c'est bon. Allez dans le sous-menu Processor type and features et vérifiez que dans Processor family, Core 2/newer Xeon soit sélectionné. (Une p'tite modif' de ma part parce que de toute façon, ce kernel est censé tourner sur des Core 2 Duo.) Si c'est le cas, c'est que le chargement du fichier de config' a marché. Ne touchez à rien.
  • Martelez la touche Echap jusqu'à ce que le menu soit quitté.
  • Maintenant, tapez sudo make clean; sudo make-kpkg clean et attendez un peu, ça va nettoyer l'environnement de tous les fichiers déjà compilés.
  • Et maintenant, accrochez-vous parce qu'on va faire la vraie compilation cette fois : sudo make-kpkg --initrd --revision=custom.1.6.3 kernel_image. Appuyez sur ENTREE. Si y'a des centaines et des centaines de lignes qui défilent au début, et que les suivantes commencent par CC, LD ou autres, c'est que votre machine est en train de compiler lui-même le noyau. Parfois, y'a quelques warnings qui s'affichent lors de la compilation de tel ou tel .o, mais ignorez-les, c'est pas très grave... D'abord, la machine compile Linux, ensuite les modules, ensuite il les convertit en .ko finaux, puis il les installe. Finalement, il crééra le .deb que l'on pourra installer pour finaliser la compilation.
  • Patientez entre 10 et 15 minutes. Eh oui, même sur un Core 2 Duo, ça prend du temps.
  • Dès que vous retrouvez avec un prompt, on va maintenant installer le noyau. Si d'aventure vous étiez en train de recompiler le noyau (au lieu de compiler celui-ci pour la première fois), tapez sudo aptitude remove linux-image-2.6.22.2 et répondez Non à la question Voulez-vous abandonner la désinstallation maintenant ? (si elle s'affiche). Sinon, sautez cette étape.
  • Finalement, tapez cd .. puis sudo dpkg -i linux-image-2.6.22.2_custom.1.6.3_i386.deb (n'hésitez pas à appuyer sur TAB (la touche au-dessus de Verr. Maj) pour que Bash complète automatiquement les noms de fichiers). Si tout va bien, Grub va dire qu'il a trouvé tant de noyaux, dont la 2.6.22.2. Si vous étiez en train de recompiler le noyau, il se peut qu'il se plaigne qu'il y ait encore un répertoire avec les modules. Ne le laissez pas arrêter l'installation juste pour ça.
  • Rebootez ! Choisissez le bon noyau dans Grub. Normalement, tout devrait bien se passer, sauf qu'il va s'arrêter sur un login console. Ça, c'est pas grave. On va donc réinstaller les drivers. Je vous suggère de commencer par le Wi-Fi parce que c'est le plus dur (et on a pas besoin de KDE pour ça.) Une fois le Wi-Fi terminé, on passera à celui de la carte graph'.
Note: Si vous recompilez votre noyau, vous pouvez bien sûr choisir une version supérieure à 1.6.3. En fait, après le --revision= vous pouvez mettre tout ce que vous voulez. Ça permet juste de surveiller plus facilement l'évolution de votre noyau au fur et à mesure que vous compilez, recompilez et recompilez le vôtre.

DRIVERS WI-FI

Pour les drivers Wi-Fi : tout dépend de votre carte. Au moment de la commande, si vous aviez choisi la carte Wireless-N, vous avez une puce 4965AGN. Sinon, c'est une 3945ABG.

Pour toutes les cartes, cette manipulation n'a besoin d'être faite qu'une seule fois. Si vous recompilez votre noyau (au lieu de le faire pour la première fois), vous pouvez sauter ceci, sinon, continuez:
  • Préparer un p'tit répertoire où on mettra notre bordel: cd ~; mkdir drivers; cd drivers; mkdir mac80211; cd mac80211
  • Télécharger un patch pour le code du noyau (va falloir recompiler ensuite): wget "http://intellinuxwireless.org/mac80211/downloads/mac80211-10.0.0.tgz"
  • Extrayez cette archive: tar xvzf mac80211-10.0.0.tgz
  • Allez dans le répertoire créé: cd mac80211.-10.0.0
  • Installez le patch: sudo make; sudo make patch_kernel
  • Recompilez le noyau: tapez cd /usr/src/linux-2.6.22.2. Refaites ensuite les étapes de la compilation du noyau à partir de l'étape 9. Rebootez.
Une fois revenu sur la console, on va installer les modules du noyau dépendant de la version patchée de mac80211. Retournez dans votre dossier drivers et crééz un 2e sous-répertoire: cd ~/drivers; mkdir iwlwifi; cd iwlwifi.

On va ici installer un firmware pour la carte Wi-Fi. Bien entendu, ceci dépend de la carte que vous avez.
Pour les cartes 4965AGN:
  • Tapez wget "http://intellinuxwireless.org/iwlwifi/downloads/iwlwifi-4965-ucode-4.44.17.tgz"
  • Tapez tar xvzf iwlwifi-4965-ucode-4.44.17.tgz
  • Tapez sudo cp iwlwifi-4965-ucode-4.44.17/iwlwifi-4965.ucode /lib/firmware/iwlwifi-4965.ucode
  • N'oubliez pas sudo ln -s /lib/firmware/iwlwifi-4965.ucode /lib/firmware/iwlwifi-4965-1.ucode
Pour les cartes 3945ABG:
  • Tapez wget "http://intellinuxwireless.org/iwlwifi/downloads/iwlwifi-3945-ucode-2.14.4.tgz"
  • Tapez tar xvzf iwlwifi-3945-ucode-2.14.4.tgz
  • Tapez sudo cp iwlwifi-3945-ucode-2.14.4/iwlwifi-3945.ucode /lib/firmware/
  • N'oubliez pas sudo ln -s /lib/firmware/iwlwifi-3945.ucode /lib/firmware/iwlwifi-3945-1.ucode
Ensuite, on va compiler le driver iwlwifi. Restez dans le même répertoire ~/drivers/iwlwifi.
Pour toutes les cartes:
  • Tapez wget "http://intellinuxwireless.org/iwlwifi/downloads/iwlwifi-0.1.15.tgz"
  • Puis tar xvzf iwlwifi-0.1.15.tgz
  • Ensuite cd iwlwifi-0.1.15
  • Puis sudo make; sudo make install
  • Puis sudo dmesg -c pour purger les messages système.
  • Finalement, sudo modprobe iwl4965 ou sudo modprobe iwl3945, selon votre carte. Tapez sudo dmesg pour voir si le chargement s'est bien déroulé.
Maintenant, on va tester le Wi-Fi. Je n'ai pas testé avec un réseau protégé WPA, parce que j'ai un WEP pour des raisons de compatibilité diverses.

Pour toutes les cartes:
  • Tapez iwconfig. Normalement, 2 nouvelles interfaces devraient être apparus: wmaster0 et wlan0. Sinon, vérifiez la position de l'interrupteur wireless sur le côté gauche de la machine, et vérifiez qu'il est bien sur la position 'I'. Sinon, essayez un p'tit reboot.
  • Tapez ifconfig wlan0 up pour activer la carte.
  • Tapez sudo iwlist wlan0 scan. Si vous avez trouvé votre réseau, c'est bon signe. Ça veut dire que vous pourrez, avec un peu de bol, vous lancer dans le wardriving (non je déconne).
  • Tapez sudo iwconfig wlan0 essid nom_de_votre_reseau.
  • Si votre réseau est protégé par WEP, tapez sudo iwconfig wlan0 key [1] votre_cle_wep.
  • Pour vérifier la config', tapez iwconfig. Si votre carte indique maintenant qu'elle est associée à votre point d'accès, vous brûlez. Sinon, refaites les commandes ci-dessus. J'ai peut-être oublié un sudo quelque part... Si Linux a fait un Kernel Panic, ça veut dire que vous avez mal installé le patch mac80211.
  • Finalement, pour demander une adresse IP, tapez dhclient wlan0. Parfois, ça peut prendre un peu de temps, soyez patients.
  • Enfin, pingez votre site favori. Si vous obtenez une réponse, bravo, vous avez réussi la partie la plus chiante de la config' de votre Linux.
CARTE GRAPHIQUE

Maintenant, on va s'occuper de la carte nVIDIA.
  • Tapez cd ~/drivers; mkdir nvidia; cd nvidia pour créér un dossier où on mettra notre driver nVIDIA.
  • Téléchargez le driver: wget "http://us.download.nvidia.com/XFree86/Linux-x86/100.14.11/NVIDIA-Linux-x86-100.14.11-pkg1.run"
  • Vérifiez que le serveur X ne tourne pas: sudo /etc/init.d/gdm stop ou sudo /etc/init.d/kdm stop selon que vous avez Ubuntu ou Kubuntu. Les Debian ont tendance à tourner GDM, mais je l'ai remplacé par KDM.
  • Lancez le prog: sudo sh NVIDIA-Linux-x86-100.14.11-pkg1.run (TAB est votre ami)
  • Dites oui pour la licence, mais dites non quand il vous demande s'il doit aller chercher sur ftp.nvidia.com pour un module précompilé; il va le compiler lui-même. N'ayez pas peur d'écraser une installation précédente, il fait tout le nettoyage tout seul comme un grand. Patientez un peu pendant qu'il fait toutes les manips. Dites oui quand il vous demande s'il doit modifier xorg.conf. Notez tous les messages d'erreur ou avertissements qu'il vous balance ! (Surtout ceux avec une histoire de pkg-config ou autres, ils sont assez embêtants.)
  • Une fois l'installation terminée, essayez maintenant sudo /etc/init.d/gdm restart ou sudo /etc/init.d/kdm restart selon votre config'. Si tout va bien, vous aurez un écran noir, puis le (superbe) logo nVIDIA au démarrage du serveur X. Vous pourrez ensuite vous logguer sur GNOME ou KDE. Mais ne le faites pas encore.
  • Rebootez!! Ceci pour voir si toutes vos modifs fonctionnent, surtout pour le driver nVIDIA. S'il ne fonctionne pas et que vous aviez relevé des messages d'erreur auparavant, corrigez-les et refaites les étapes 4 à 7.


SON AVEC ALSA

Au passage, testez le son avec la commande aplay /dev/urandom. Un bruit blanc horriblement fort confirme le fonctionnement de la carte son. Tapez Ctrl+C pour arrêter aplay. Bien que la config' de mon noyau soit telle que ça marche sur ma machine, il faut Alsa version 1.0.14. Pour une Debian, cette version est malheureusement encore dans le répertoire unstable, il faudra modifier /etc/apt/sources.list. Pour une Ubuntu, cette version est disponible dans les répertoires par défaut. Il vous faudra les paquets alsa-base, alsa-firmware-loaders, alsa-oss, alsa-tools, alsa-utils version 1.0.14 ou 1.0.14a. Rebootez.

Les hauts-parleurs doivent aussi être coupés maintenant, quand vous branchez un casque. Pour le confirmer, bootez sans casque dans la prise jack, tapez aplay /dev/urandom, et pendant que aplay vous fait ce bruit blanc, branchez le casque. Normalement, le son est coupé dans les hauts-parleurs. J'espère pour vous que ça marche aussi, je ne peux rien dire ;-)

Ceci conclut mon post très très long, et toutes les manips que j'ai fait pour faire marcher Linux sur cette formidable machine. Il se peut qu'il manque encore un ou deux trucs, je posterai au fur et à mesure.

TRES IMPORTANT: Ne téléchargez PLUS les mises à jour pour le noyau via Adept ou Synaptic (donc pas les linux-image-quelquechose et autres) ! Sinon tout sera cassé ! Si vous voulez mettre à jour votre noyau, vous devrez le recompiler et refaire TOUTES les étapes mentionnées ci-dessus !

Voir le messageSnip_oX, le le 09-09-07 à 11:12:05, dit :

Est-ce que tu aurais des forums sur lesquels je pourrais apprendre les bases de Linux?


Y'a les forums Ubuntu français, je pense qu'on t'apprendra tout. Perso, je n'ai pas Ubuntu mais Debian, et je sais que l'installation d'Ubuntu est radicalement différente de Debian, même si Debian a servi de base pour Ubuntu.

Fichier(s) joint(s)

  • Fichier joint  config.txt (61.91 Ko)
    Nombre de téléchargements : 66

Ce message a été modifié par Marx0r - 25 March 2008 à 22:28:43.

Config:
Inspiron 1720, Core 2 Duo T7100 @ 1,80GHz, nVIDIA 8600GT, 160Go + 500Go SATA, 2Go RAM, Intel 4965AGN, Bluetooth, clavier QWERTY-US, Gentoo Linux

<Ishen> Windows ? Voilà un nom très indicatif de par où il faut balancer cet OS... (BashFR)

<Noche> Le problème avec linux, c'est que des fois ça tombe en panne
<Noche> Le problème avec Windows, c'est que des fois ça tombe en marche
(BashFR)
0

#59 L'utilisateur est hors-ligne   Daëavelwyn Icône

  • Newbie
  • Groupe : Membre
  • Messages : 16
  • Inscrit(e) : 29 Aug 07

Posté 15 September 2007 à 18:43:23

Bon...et bien marxor, je crois que tu es mon nouveau kernelus deus :P Ton tuto est niquel et le pire, c'est qu'il marche niquel ^_^ j'ai réglé presque tous mes problèmes, et en tout cas les plus important. Me reste a tester l'ACPI pour la mise en veille et mise en veille prolongée.
Encore un grand merci à toi, peut-etre devrais tu proposer ton tuto sur le forum/wiki ubuntu :)

Ce message a été modifié par Daëavelwyn - 15 September 2007 à 18:44:51.

0

#60 L'utilisateur est hors-ligne   Daëavelwyn Icône

  • Newbie
  • Groupe : Membre
  • Messages : 16
  • Inscrit(e) : 29 Aug 07

Posté 18 September 2007 à 09:14:29

Bon, je poste la suite, pour l'ACPI, je pense que c'est mort, mise en veille et mise en veille prolongée ne reprennent pas :( ... Par contre, j'avais réussi à récupérer la molette sur le pad et là, je l'ai de nouveau perdu, impossible de faire un scroll kan je glisse mon doigt sur le bord du pad :/
0

Partager ce sujet :


  • 7 Pages +
  • 1
  • 2
  • 3
  • 4
  • 5
  • Dernière »
  • Vous ne pouvez pas commencer un sujet
  • Vous ne pouvez pas répondre à ce sujet

2 utilisateur(s) en train de lire ce sujet
0 membre(s), 2 invité(s), 0 utilisateur(s) anonyme(s)